aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2023-05-25 10:15:47 +0200
committerMatěj Cepl <mcepl@cepl.eu>2023-05-25 11:01:18 +0200
commitec4b49d843e67b31b33ac81bef55346353f1d04c (patch)
tree5f60ffae4d6ebe180c5ee4d51d468bf154535251 /pyproject.toml
parent8006d981ce26fe8c1140e33b9476c08470d59f30 (diff)
downloadpyg-ec4b49d843e67b31b33ac81bef55346353f1d04c.tar.gz
refactor: rearrange the project to the src/ layout.0.10.3
Fix also pyproject.toml to generate what seems right. Add the explicit dependency on nntplib for Python >= 3.12 (gh#python/cpython!104894). Fixes: https://todo.sr.ht/~mcepl/pygn/7
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml22
1 files changed, 11 insertions, 11 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 35a7abf..1cbc27c 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,5 +1,5 @@
[build-system]
-requires = ["setuptools"]
+requires = ["setuptools", "wheel"]
build-backend = "setuptools.build_meta"
[project]
@@ -8,8 +8,8 @@ authors = [
{name = "Cosimo Alfarano", email = "kalfa@debian.org"},
{name = "Matěj Cepl", email = "mcepl@cepl.eu"},
]
+description = 'The Python Gateway Script: news2mail mail2news gateway'
keywords=["nntp", "email", "gateway"]
-readme = "README.md"
requires-python = ">=3.6"
license = {text = "GPL-3.0"}
classifiers = [
@@ -23,9 +23,15 @@ classifiers = [
'License :: OSI Approved :: GNU General Public License v3 (GPLv3)'
]
dependencies = [
- "rply",
+ 'rply',
+ 'nntplib; python_version>="3.12"'
]
-dynamic = ["version", "description"]
+dynamic = ["version", "readme"]
+
+[project.urls]
+Homepage = "https://sr.ht/~mcepl/pygn/"
+"Bug Tracker" = "https://todo.sr.ht/~mcepl/pygn"
+Repository = "https://git.sr.ht/~mcepl/pygn"
[project.scripts]
pygm2n = "mail2news:main"
@@ -33,10 +39,4 @@ pygn2m = "news2mail:main"
[tool.setuptools.dynamic]
version = {attr = "mail2news.__version__"}
-description = {attr = "mail2news.__description__"}
-
-[tool.setuptools.packages.find]
-where = ["."]
-include = ["*.py"]
-exclude = ["setup.py"]
-namespaces = false
+readme = {file = "README.md"}