aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2023-03-02 10:34:11 +0100
committerMatěj Cepl <mcepl@cepl.eu>2023-05-25 10:56:30 +0200
commit8006d981ce26fe8c1140e33b9476c08470d59f30 (patch)
tree9e68d90a64d8eb3196ffdef9dc89789097c1c312 /pyproject.toml
parent458dd9bdb4a0346b09112659af66b560cefa1d98 (diff)
downloadpyg-8006d981ce26fe8c1140e33b9476c08470d59f30.tar.gz
WIP: pyproject_toml.
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml42
1 files changed, 42 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..35a7abf
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,42 @@
+[build-system]
+requires = ["setuptools"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "pygn"
+authors = [
+ {name = "Cosimo Alfarano", email = "kalfa@debian.org"},
+ {name = "Matěj Cepl", email = "mcepl@cepl.eu"},
+]
+keywords=["nntp", "email", "gateway"]
+readme = "README.md"
+requires-python = ">=3.6"
+license = {text = "GPL-3.0"}
+classifiers = [
+ "Programming Language :: Python :: 3",
+ 'Development Status :: 3 - Alpha',
+ 'Intended Audience :: System Administrators',
+ 'Topic :: Utilities',
+ 'Topic :: Communications :: Usenet News',
+ 'Environment :: Console',
+ 'Operating System :: OS Independent',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)'
+]
+dependencies = [
+ "rply",
+]
+dynamic = ["version", "description"]
+
+[project.scripts]
+pygm2n = "mail2news:main"
+pygn2m = "news2mail:main"
+
+[tool.setuptools.dynamic]
+version = {attr = "mail2news.__version__"}
+description = {attr = "mail2news.__description__"}
+
+[tool.setuptools.packages.find]
+where = ["."]
+include = ["*.py"]
+exclude = ["setup.py"]
+namespaces = false