aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAdam Stokes <adam.stokes@ubuntu.com>2013-10-30 22:14:55 -0400
committerAdam Stokes <adam.stokes@ubuntu.com>2013-10-30 22:14:55 -0400
commitcd99ebea74a606fe037580eead2702f4c2dd7c65 (patch)
tree3ab32f8ed6a19d2dfbfa87d8c55f86bdd0e509a7 /setup.py
parentc398e45ce3e22062df08c2d4f9dc1eed1ee99e1d (diff)
downloadsos-cd99ebea74a606fe037580eead2702f4c2dd7c65.tar.gz
Python 3 port
This includes a necessary dependency on python-six for its compability layer since we are wanting to continue support for both Python 2.7.x and Python 3.x. In addition, this will allow us to effectively phase out Python 2 support when/if the time arises that all interested distributions have done away with Python 2. This port passes all unittests for both python 2.7.x and python 3.3.x Signed-off-by: Adam Stokes <adam.stokes@ubuntu.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index f24bcae8..eb20a12c 100644
--- a/setup.py
+++ b/setup.py
@@ -32,7 +32,7 @@ class BuildData(build):
rc = subprocess.call(['msgfmt', '-o', mo, po])
if rc != 0:
raise Warning("msgfmt returned %d" % (rc,))
- except Exception, e:
+ except Exception as e:
error("Failed gettext.")
sys.exit(1)