aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorAdam Spiers <git@adamspiers.org>2018-05-16 23:26:25 +0100
committerAdam Spiers <git@adamspiers.org>2018-05-16 23:26:25 +0100
commit64071ebba7443400227b889a9f204398f6b1ee0a (patch)
treed7c5d49761dd3b396ecd6a89d3a0a1111d782ed8 /setup.py
parent2fb3e7941077d992b2a60f4cac858b2c8f2e7f46 (diff)
downloadgit-deps-64071ebba7443400227b889a9f204398f6b1ee0a.tar.gz
avoid PyScaffold bug with newer setuptools
https://github.com/blue-yonder/pyscaffold/issues/148 Why the HELL is setup_requires choosing to install PyScaffold 2.5.6 when 2.5.10 is available and within the constraints? That would be far too sensible, wouldn't it?
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4df7bcb..4b84cc1 100644
--- a/setup.py
+++ b/setup.py
@@ -3,7 +3,7 @@
"""
Setup file for git_deps.
- This file was generated with PyScaffold 2.5.6, a tool that easily
+ This file was generated with PyScaffold, a tool that easily
puts up a scaffold for your new Python project. Learn more under:
http://pyscaffold.readthedocs.org/
"""
@@ -18,7 +18,7 @@ def setup_package():
setup(
setup_requires=[
'six',
- 'pyscaffold>=2.5a0,<2.6a0',
+ 'pyscaffold>=2.5.10,<2.6a0',
'setuptools-markdown',
] + sphinx,
long_description_markdown_filename='README.md',