aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py22
1 files changed, 3 insertions, 19 deletions
diff --git a/setup.py b/setup.py
index 23be5aa..5bce6c2 100644
--- a/setup.py
+++ b/setup.py
@@ -1,21 +1,5 @@
-from distutils.core import setup
-import os
+#!/usr/bin/env python3
-# Please run
-# python setup.py install
+import setuptools
-if os.path.exists('doc/mount.wikipediafs.1.gz'):
- df = [('/usr/share/man/man1/', ['doc/mount.wikipediafs.1.gz'])]
-else:
- df = []
-
-setup(
- name = 'wikipediafs',
- author = 'Mathieu Blondel',
- author_email = 'mblondel@users.sourceforge.net',
- url = 'http://wikipediafs.sourceforge.net',
- packages = ['wikipediafs'],
- package_dir = {'wikipediafs':'src/wikipediafs/'},
- scripts = ['src/mount.wikipediafs'],
- data_files = df,
-) \ No newline at end of file
+setuptools.setup()