aboutsummaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2024-09-03 23:58:04 +0200
committerMatěj Cepl <mcepl@cepl.eu>2024-09-04 00:27:45 +0200
commit8f9c132fadc2836f8c56b50972df732236bf493c (patch)
treeebafe1cd70d1d70568ef9fc705bf5b96f43ff886 /setup.cfg
parent13bac75a24e98c7b8a8c88bbd9050b9be573ad42 (diff)
downloadwikipediafs-8f9c132fadc2836f8c56b50972df732236bf493c.tar.gz
fix: convert from setup.py to setup.cfg
And empty setup.py (python3 -mbuild . doesn't work without it)
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg55
1 files changed, 55 insertions, 0 deletions
diff --git a/setup.cfg b/setup.cfg
new file mode 100644
index 0000000..37b9450
--- /dev/null
+++ b/setup.cfg
@@ -0,0 +1,55 @@
+[metadata]
+name = wikipediafs
+version = attr: wikipediafs.__version__
+author = Mathieu Blondel
+author_email = mblondel@users.sourceforge.net
+maintainer = Matej Cepl
+maintainer_email = mcepl@cepl.eu
+description = View and edit Wikipedia articles as if they were real files
+license = GPL
+classifiers =
+ Development Status :: 5 - Production/Stable
+ Intended Audience :: Developers
+ License :: OSI Approved :: GPL
+ Operating System :: OS Independent
+ Programming Language :: Python
+ Programming Language :: Python :: 3
+ Programming Language :: Python :: 3.6
+ Programming Language :: Python :: 3.7
+ Programming Language :: Python :: 3.8
+ Programming Language :: Python :: 3.9
+ Programming Language :: Python :: 3.10
+ Programming Language :: Python :: 3.11
+ Programming Language :: Python :: 3.12
+project_urls =
+ home_page = https://wikipediafs.sourceforge.net/
+ source = https://git.sr.ht/~mcepl/wikipediafs
+ report = https://lists.sr.ht/~mcepl/devel
+ changelog = https://git.sr.ht/~mcepl/m2crypto/tree/master/item/CHANGES
+
+[options]
+zip_safe = False
+include_package_data = True
+package_dir=
+ =src
+packages = find:
+install_requires =
+ fuse-python
+
+[options.packages.find]
+where=src
+exclude =
+ contrib*
+ docs*
+ tests*
+
+[egg_info]
+tag_build =
+tag_svn_revision = 0
+
+[flake8]
+; ignore = E402,E501,E731,N806,N803,N802,E265
+ignore = E402,N806,N803,N802,E501
+
+[pydocstyle]
+ignore = D10,D203,D213