aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 3 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 9fdad76..e74d78a 100644
--- a/setup.py
+++ b/setup.py
@@ -17,7 +17,8 @@ class Build_WLP_ext(build_ext):
# that's how it should be.
# otherwise, subsequent calls down the stack unwind the list and
# check_call won't get it.
- ([['yacc', '-d', '-o', 'wlp/commands.tab.c', 'wlp/commands.y']]),
+ ([['yacc', '-d', '-o', 'wlp_c/commands.tab.c',
+ 'wlp_c/commands.y']]),
'Generating lexer')
self.make_file(
'wlp/commands.l', 'wlp/lex.yy.c', check_call,
@@ -53,7 +54,7 @@ setup(name='pygn',
},
# TODO package actually requires lex and yacc port, but not sure
# how to say it here
- requires=[],
+ requires=['rply'],
license="GPLv3",
keywords=["nntp", "email", "gateway"],
classifiers=[