aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py15
1 files changed, 8 insertions, 7 deletions
diff --git a/setup.py b/setup.py
index aa19e66..fe06736 100644
--- a/setup.py
+++ b/setup.py
@@ -1,6 +1,8 @@
-#!/usr/bin/python3
+#!/usr/bin/python
# -*- coding: utf-8 -*-
+from __future__ import print_function
+from __future__ import absolute_import
from mail2news import VERSION, DESC
import os.path
from setuptools import setup
@@ -20,18 +22,17 @@ setup(name='pygn',
py_modules=['mail2news', 'news2mail', 'setup',
'whitelist', 'wlp', 'wlp_parser'],
test_suite="test",
- entry_points={
- "console_scripts": [
- "pygm2n = mail2news:main",
- "pygn2m = news2mail:main"
- ]
- },
+ scripts=['pygm2n', 'pygn2m'],
requires=['rply'],
license="GPLv3",
keywords=["nntp", "email", "gateway"],
classifiers=[
'Development Status :: 3 - Alpha',
'Programming Language :: Python :: 2.7',
+ 'Programming Language :: Python :: 3',
+ 'Programming Language :: Python :: 3.4',
+ 'Programming Language :: Python :: 3.5',
+ 'Programming Language :: Python :: 3.6',
'Intended Audience :: System Administrators',
'Topic :: Utilities',
'Topic :: Communications :: Usenet News',