aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2015-01-03 08:59:56 +0100
committerMatěj Cepl <mcepl@cepl.eu>2015-01-03 09:14:36 +0100
commite0f8a7e01bf034f8dd5f26f7dbd0e32be4360cba (patch)
treecc10a76862b67271fb74a42dfbdcfe3ddbdea256 /setup.py
parentbc74057f5b075e4eab2aa6698821d33e1d97c7d5 (diff)
downloadpygn-e0f8a7e01bf034f8dd5f26f7dbd0e32be4360cba.tar.gz
Renaming because of conflicting (dead) PIP package.
Also, fix package metadata.
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 716c101..063697d 100644
--- a/setup.py
+++ b/setup.py
@@ -37,12 +37,13 @@ wlp_module = Extension('wlp',
'wlp/lex.yy.c'])
-setup(name='pyg',
+setup(name='pygn',
version=VERSION, # the current Debian version is 0.9.8
author="Cosimo Alfarano, Matej Cepl",
author_email="kalfa@debian.org, mcepl@cepl.eu",
description=DESC,
long_description=read('README'),
+ url='https://gitlab.com/mcepl/pyg',
py_modules=['mail2news', 'news2mail', 'setup', 'whitelist'],
ext_modules=[wlp_module],
test_suite="test",
@@ -53,14 +54,14 @@ setup(name='pyg',
# TODO package actually requires lex and yacc port, but not sure
# how to say it here
requires=[],
- license="GPLv2",
+ license="GPLv3",
keywords=["nntp", "email", "gateway"],
classifiers=[
'Development Status :: 3 - Alpha',
'Programming Language :: Python :: 2.7',
- 'Natural Language :: English',
- 'Topic :: Office/Business :: Financial :: Accounting',
+ 'Intended Audience :: System Administrators',
'Topic :: Utilities',
+ 'Topic :: Communications :: Usenet News',
'Environment :: Console',
'Operating System :: OS Independent',
'License :: OSI Approved :: GNU Affero General Public License v3'