aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml27
1 files changed, 27 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..7b190cb
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,27 @@
+[project]
+name = "osm_where"
+description = "Get geo: URI for given locality from OSM"
+version = "0.1.0"
+requires-python = ">=3.6"
+authors = [
+ { name = "Matěj Cepl", email = "mcepl@cepl.eu" }
+]
+license = { file="LICENSE" }
+readme = "README.md"
+dependencies = [
+ "OSMPythonTools",
+]
+classifiers = [
+ "Programming Language :: Python :: 3",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Topic :: Scientific/Engineering :: GIS",
+ "Environment :: Console",
+]
+
+[project.scripts]
+osm_where = "osm_where:main"
+
+[build-system]
+requires = ["setuptools>=61.0"]
+build-backend = "setuptools.build_meta"