aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@redhat.com>2014-01-08 14:13:30 +0100
committerMatěj Cepl <mcepl@redhat.com>2014-01-11 11:31:39 +0100
commit9a43d17636e6f77eb93d5c4d3653f36b3348851a (patch)
tree3ea5cb61ee0557ab560be4dc08e76f8ce348e93e /setup.py
parent532b2f96e27201df320988ab2a61dadd230843a7 (diff)
downloadgg_scraper-9a43d17636e6f77eb93d5c4d3653f36b3348851a.tar.gz
Make whole script comaptible with python 2.6
How low we fell :( Also: * On Python 2.6 we have to send bytes to proc.communicate() not unicode str (Fixes #288)
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index ccaec04..331e57e 100644
--- a/setup.py
+++ b/setup.py
@@ -1,7 +1,10 @@
# -*- coding: utf-8 -*-
from __future__ import absolute_import, print_function, unicode_literals
from distutils.core import setup, Command
-import unittest
+try:
+ import unittest2 as unittest
+except ImportError:
+ import unittest
import gg_scraper