aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@redhat.com>2014-01-04 19:19:18 +0100
committerMatěj Cepl <mcepl@redhat.com>2014-01-04 19:19:18 +0100
commit0f9f919c206711b767029d1aa59ae979bbb69d51 (patch)
tree72fe207bdc4774e3ddf155cf253f4c556da12adc /setup.py
parente67efc76fd37ae449cbb507fd0ef0e264e11fc36 (diff)
downloadgg_scraper-0f9f919c206711b767029d1aa59ae979bbb69d51.tar.gz
Make at least unittests running with Python 2.7
Add support for Travis-CI Fixes #283
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index a29fd4e..bec4529 100644
--- a/setup.py
+++ b/setup.py
@@ -1,3 +1,5 @@
+# -*- coding: utf-8 -*-
+from __future__ import absolute_import, print_function, unicode_literals
from distutils.core import setup, Command
import unittest
@@ -51,4 +53,5 @@ setup(name='gg_scrapper',
classifiers=classifiers,
cmdclass={
'test': RunTests,
- })
+ },
+ requires=['beautifulsoup4', 'PyYAML'])