aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml7
1 files changed, 7 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 6977d9f..191a3dc 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -9,6 +9,9 @@ packages = [
{ include = "epy_extras" },
]
+[tool.poetry.scripts]
+epy = "epy:main"
+
[tool.poetry.dependencies]
python = "^3.7"
windows-curses = { version = "*", markers = "platform_system == 'Windows'" }
@@ -27,3 +30,7 @@ strict_optional = true
[tool.black]
line-length = 100
target-version = ['py38']
+
+[build-system]
+requires = ["poetry-core>=1.0.0"]
+build-backend = "poetry.core.masonry.api"