aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorBenawi Adha <43810055+wustho@users.noreply.github.com>2019-10-23 23:22:20 +0700
committerGitHub <noreply@github.com>2019-10-23 23:22:20 +0700
commit63a6791ee34b24e79a3eba93317c5fc5014c7259 (patch)
tree0fc17d05c9eb8c66afe5095deb52814d048c923f /setup.py
parentb68cf694c3f841381631b3bf27136e15a4e1e9d4 (diff)
downloadepy-63a6791ee34b24e79a3eba93317c5fc5014c7259.tar.gz
Add files via upload
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py17
1 files changed, 17 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..2057e08
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,17 @@
+import sys
+from setuptools import setup
+from epy import __version__, __author__, __url__, __license__
+
+setup(
+ name = "epy",
+ version = __version__,
+ description = "Terminal/CLI Epub Reader (Fork of https://github.com/wustho/epr with Reading Pctg)",
+ url = __url__,
+ author = __author__,
+ license = __license__,
+ keywords = ["EPUB", "EPUB3", "CLI", "Terminal", "Reader"],
+ install_requires = ["windows-curses"] if sys.platform == "win32" else [],
+ python_requires = "~=3.0",
+ py_modules = ["epy"],
+ entry_points = { "console_scripts": ["epy = epy:main"] }
+)