aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorbenadha <benawiadha@gmail.com>2021-10-23 16:16:36 +0700
committerbenadha <benawiadha@gmail.com>2021-10-23 16:16:36 +0700
commit12c49f6dd18a1b736a43d80472b1d0da9023cc24 (patch)
treea35225579beb792d4a526aed32e37fcea51852ed /setup.py
parent55f938c3dcbb91c91f2e9bee01556bf8da97158d (diff)
downloadepy-12c49f6dd18a1b736a43d80472b1d0da9023cc24.tar.gz
v2021.10.23: Major refactoring
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py8
1 files changed, 4 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 37ff7ca..9af22b7 100644
--- a/setup.py
+++ b/setup.py
@@ -10,7 +10,7 @@ if sys.platform == "win32":
setup(
name="epy-reader",
- version="2021.8.14",
+ version="2021.10.23",
description="Terminal/CLI Ebook (epub, fb2, mobi, azw3) Reader",
long_description=long_description,
long_description_content_type="text/markdown",
@@ -20,12 +20,12 @@ setup(
license="GPL-3.0",
keywords=["epub", "epub3", "fb2", "mobi", "azw3", "CLI", "Terminal", "Reader"],
install_requires=requirements,
- python_requires="~=3.0",
+ python_requires="~=3.7",
py_modules=["epy"],
- entry_points={ "console_scripts": ["epy = epy:main"] },
+ entry_points={"console_scripts": ["epy = epy:main"]},
classifiers=[
"Programming Language :: Python :: 3",
"License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
"Operating System :: OS Independent",
- ]
+ ],
)