aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py29
1 files changed, 29 insertions, 0 deletions
diff --git a/setup.py b/setup.py
new file mode 100644
index 0000000..6e5a25a
--- /dev/null
+++ b/setup.py
@@ -0,0 +1,29 @@
+#!/usr/bin/env python3
+
+from setuptools import setup, find_packages
+
+setup(
+ name="epubgrep",
+ version="0.2.0",
+ description='Grep through EPub files',
+ author=u'Matěj Cepl',
+ author_email='mcepl@cepl.eu',
+ url='https://gitlab.com/mcepl/epubgrep',
+ packages=find_packages(),
+ test_suite='tests',
+ install_requires=['epub_meta'],
+ classifiers=[
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.3",
+ "Programming Language :: Python :: 3.4",
+ "Programming Language :: Python :: 3.5",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.7",
+ "Environment :: Console",
+ "Intended Audience :: Information Technology",
+ "License :: OSI Approved :: MIT License",
+ "Operating System :: OS Independent",
+ "Topic :: Software Development :: Libraries :: Python Modules",
+ ],
+)