aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml40
1 files changed, 25 insertions, 15 deletions
diff --git a/pyproject.toml b/pyproject.toml
index 547984d..88a9480 100644
--- a/pyproject.toml
+++ b/pyproject.toml
@@ -1,28 +1,38 @@
-[build-system]
-requires = ["setuptools>=61.2"]
-build-backend = "setuptools.build_meta"
-
[project]
name = "epubgrep"
-version = "0.9.0"
-authors = [{name = "Matěj Cepl", email = "mcepl@cepl.eu"}]
description = "Grep through EPub files"
+version = "0.10.0"
+authors = [
+ { name = "Matěj Cepl", email = "mcepl@cepl.eu" }
+]
+license = { file="LICENSE" }
+readme = "README.md"
+dependencies = [
+ "epub_meta",
+]
classifiers = [
- "Programming Language :: Python :: 3",
- "Programming Language :: Python :: 3.3",
- "Programming Language :: Python :: 3.4",
- "Programming Language :: Python :: 3.5",
- "Programming Language :: Python :: 3.6",
- "Programming Language :: Python :: 3.7",
- "Programming Language :: Python :: 3.7",
"Environment :: Console",
"Intended Audience :: Information Technology",
"License :: OSI Approved :: MIT License",
"Operating System :: OS Independent",
+ "Programming Language :: Python :: 3",
+ "Programming Language :: Python :: 3.6",
+ "Programming Language :: Python :: 3.7",
+ "Programming Language :: Python :: 3.8",
+ "Programming Language :: Python :: 3.9",
+ "Programming Language :: Python :: 3.10",
+ "Programming Language :: Python :: 3.11",
+ "Programming Language :: Python :: 3.12",
"Topic :: Software Development :: Libraries :: Python Modules",
]
-urls = {Homepage = "https://git.cepl.eu/cgit/epubgrep"}
-dependencies = ["epub_meta"]
[project.scripts]
epubgrep = "epubgrep:main"
+
+[project.urls]
+homepage = "https://git.cepl.eu/cgit/toys/epubgrep/"
+repository = "https://git.cepl.eu/git/toys/epubgrep"
+
+[build-system]
+requires = ["setuptools>=61.0"]
+build-backend = "setuptools.build_meta"