aboutsummaryrefslogtreecommitdiffstats
path: root/apps/X11/InstallMgr/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'apps/X11/InstallMgr/Makefile.am')
-rw-r--r--apps/X11/InstallMgr/Makefile.am25
1 files changed, 25 insertions, 0 deletions
diff --git a/apps/X11/InstallMgr/Makefile.am b/apps/X11/InstallMgr/Makefile.am
new file mode 100644
index 0000000..6adb3cc
--- /dev/null
+++ b/apps/X11/InstallMgr/Makefile.am
@@ -0,0 +1,25 @@
+## Process this file with automake to produce Makefile.in
+
+SUBDIRS = intl po macros vcl src
+
+install-data-local:
+ @$(NORMAL_INSTALL)
+ if test -d $(srcdir)/pixmaps; then \
+ $(mkinstalldirs) $(DESTDIR)@PACKAGE_PIXMAPS_DIR@; \
+ for pixmap in $(srcdir)/pixmaps/*; do \
+ if test -f $$pixmap; then \
+ $(INSTALL_DATA) $$pixmap $(DESTDIR)@PACKAGE_PIXMAPS_DIR@; \
+ fi \
+ done \
+ fi
+
+dist-hook:
+ if test -d pixmaps; then \
+ mkdir $(distdir)/pixmaps; \
+ for pixmap in pixmaps/*; do \
+ if test -f $$pixmap; then \
+ cp -p $$pixmap $(distdir)/pixmaps; \
+ fi \
+ done \
+ fi
+