aboutsummaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@gmail.com>2020-06-26 16:59:08 -0700
committerFredrik Salomonsson <plattfot@gmail.com>2020-06-26 16:59:08 -0700
commitcf7d95e09f69f420e2da5c333c3d01a2555c63ce (patch)
tree808933fbb59e4336066fc777365c19081a9d43b4 /configure.ac
parente9c0fa906ecc09b814f88c7ab7d6412fefcb2dcd (diff)
parent14711963d4cdf7d20ad0e1803c7cc58c858adc1b (diff)
downloadpinentry-rofi-2.0.0.tar.gz
Merge branch 'hall'2.0.0
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac35
1 files changed, 35 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..3b625aa
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,35 @@
+
+dnl -*- Autoconf -*-
+
+AC_INIT(pinentry-rofi, 2.0.0)
+AC_SUBST(HVERSION, "\"2.0.0\"")
+AC_SUBST(AUTHOR, "\"Fredrik Salomonsson\"")
+AC_SUBST(COPYRIGHT, "'(2020)")
+AC_SUBST(LICENSE, gpl3+)
+AC_CONFIG_SRCDIR(pinentry-rofi.scm)
+AC_CONFIG_AUX_DIR([build-aux])
+AM_INIT_AUTOMAKE([1.12 gnu silent-rules subdir-objects color-tests parallel-tests -Woverride -Wno-portability])
+AM_SILENT_RULES([yes])
+
+AC_CONFIG_FILES([Makefile])
+AC_CONFIG_FILES([pre-inst-env], [chmod +x pre-inst-env])
+AC_CONFIG_FILES([scripts/pinentry-rofi],[chmod +x scripts/pinentry-rofi])
+dnl Search for 'guile' and 'guild'. This macro defines
+dnl 'GUILE_EFFECTIVE_VERSION'.
+GUILE_PKG([3.0 2.2 2.0])
+GUILE_PROGS
+GUILE_SITE_DIR
+if test "x$GUILD" = "x"; then
+ AC_MSG_ERROR(['guild' binary not found; please check your guile-2.x installation.])
+fi
+
+dnl Hall auto-generated guile-module dependencies
+
+
+dnl Installation directories for .scm and .go files.
+guilemoduledir="${datarootdir}/guile/site/$GUILE_EFFECTIVE_VERSION"
+guileobjectdir="${libdir}/guile/$GUILE_EFFECTIVE_VERSION/site-ccache"
+AC_SUBST([guilemoduledir])
+AC_SUBST([guileobjectdir])
+
+AC_OUTPUT