aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorFredrik Salomonsson <plattfot@posteo.net>2021-01-30 17:15:25 -0800
committerFredrik Salomonsson <plattfot@posteo.net>2021-01-31 15:33:24 -0800
commitd14f35dd8eddfacdab6380e1e36f73b1c5355270 (patch)
tree6c40455ba5dc01d4b93d28946e9370f4f06451ea /Makefile.am
parentee0a2d186d50d838da46858f982b2c81e9a6b17c (diff)
downloadpinentry-rofi-d14f35dd8eddfacdab6380e1e36f73b1c5355270.tar.gz
Fix the issue with the error "no code for module (pinentry-rofi)"
Update the autoconf and automake to compute the relative path to the module and object path. This adds a dependency on autoconf-archive for computing the relative paths.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index d499bf6..f6eeea3 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,8 @@ do_subst = $(SED) \
-e 's,[@]GUILE[@],$(GUILE),g' \
-e 's,[@]guilemoduledir[@],$(guilemoduledir),g' \
-e 's,[@]guileobjectdir[@],$(guileobjectdir),g' \
+ -e 's,[@]GUILE_OBJECT_DIR[@],$(prefix)/$(GUILE_OBJECT_DIR),g' \
+ -e 's,[@]GUILE_MODULE_DIR[@],$(exec_prefix)/$(GUILE_MODULE_DIR),g' \
-e 's,[@]localedir[@],$(localedir),g'
nodist_noinst_SCRIPTS = pre-inst-env