aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@redhat.com>2012-03-31 13:45:45 +0200
committerMatěj Cepl <mcepl@redhat.com>2012-03-31 13:46:56 +0200
commitd7b122f17ebc23b0ea8bd0cf1df3bc854a9a595b (patch)
treed015e556ec803c9a13d07ea1735ab8cd73577b02 /setup.py
parent53d7ba3e2712585c51a19f6fcc3b7ff1e5e49e2e (diff)
downloadyamlish-d7b122f17ebc23b0ea8bd0cf1df3bc854a9a595b.tar.gz
We really don't need NEWS.txt. Git log is enough and it is just confusing.0.7
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py7
1 files changed, 1 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index b9c05ed..da697e1 100644
--- a/setup.py
+++ b/setup.py
@@ -27,11 +27,6 @@ def read(fname):
with open(os.path.join(os.path.dirname(__file__), fname)) as inf:
return "\n" + inf.read().replace("\r\n", "\n")
-def get_long_description():
- return read("README.txt") \
- + "\nChangelog:\n" + "=" * 10 + "\n" \
- + read("NEWS.txt")
-
setup(
name='yamlish',
version=str(yamlish.__version__),
@@ -40,7 +35,7 @@ setup(
author_email='mcepl@redhat.com',
url='https://gitorious.org/yamlish',
py_modules=['yamlish'],
- long_description=get_long_description(),
+ long_description=read("README.txt"),
keywords=['TAP', 'YAML', 'yamlish'],
cmdclass={'test': RunTests},
classifiers=[