diff options
author | Matěj Cepl <mcepl@redhat.com> | 2012-04-24 07:27:20 +0200 |
---|---|---|
committer | Matěj Cepl <mcepl@redhat.com> | 2012-04-24 07:27:20 +0200 |
commit | 653699a56f8e3ebfa4f19e098f03bd817beb9680 (patch) | |
tree | 5c68d4b8493b49143b84718d0981b97bada4aa62 /setup.py | |
parent | 2229c24f95d502ff269deedc6c4b66aa30f8acd1 (diff) | |
download | json_diff-1.3.3.tar.gz |
python 2.4 compatibility ... we don't have context managers.1.3.3
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 6 |
1 files changed, 4 insertions, 2 deletions
@@ -24,8 +24,10 @@ class RunTests(Command): def read(fname): - with open(os.path.join(os.path.dirname(__file__), fname)) as f: - return "\n" + f.read().replace("\r\n", "\n") + f = open(os.path.join(os.path.dirname(__file__), fname)) + out = "\n" + f.read().replace("\r\n", "\n") + f.close() + return out def get_long_description(): |