aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2014-05-22 07:30:06 -0400
committerMatěj Cepl <mcepl@redhat.com>2014-05-22 13:32:40 +0200
commitc7a0434ba4ce0e83bc179221cd2d5fd583f4bd8b (patch)
treeaa0d7d6faac87b8878707eec23cc08d5d60928a4 /setup.py
parent426540a5a19ef772ae477ee0a37d4d6f0351c556 (diff)
parent51bdad571d30c551fb7e1f38813d106304c7daa8 (diff)
downloadcucutags-c7a0434ba4ce0e83bc179221cd2d5fd583f4bd8b.tar.gz
Merged #1 "Replace distutils with setuptools (and simplify setup.py)"0.6.1
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py24
1 files changed, 2 insertions, 22 deletions
diff --git a/setup.py b/setup.py
index 9ba697e..1175581 100644
--- a/setup.py
+++ b/setup.py
@@ -1,28 +1,8 @@
# coding: utf-8
from __future__ import absolute_import, print_function
-from distutils.core import setup, Command
+from setuptools import setup
import os.path
import cucutags
-import unittest
-
-
-class RunTests(Command):
- """New setup.py command to run all tests for the package.
- """
- description = "run all tests for the package"
-
- user_options = []
-
- def initialize_options(self):
- pass
-
- def finalize_options(self):
- pass
-
- def run(self):
- tests = unittest.TestLoader().discover('.')
- runner = unittest.TextTestRunner(verbosity=2)
- runner.run(tests)
def read(fname):
@@ -38,7 +18,7 @@ setup(
author_email='mcepl@redhat.com',
url='https://gitorious.org/cucutags/cucutags/',
long_description=read("README"),
- cmdclass={'test': RunTests},
+ test_suite='test',
keywords=['BDD', 'behave', 'ctags', 'tags'],
classifiers=[
"Programming Language :: Python",