summaryrefslogtreecommitdiffstats
path: root/package.spec
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2021-03-06 02:34:40 +0100
committerMatěj Cepl <mcepl@cepl.eu>2021-03-06 02:35:18 +0100
commit78c42d24842a9df57b0279a75a5d0d6544100d35 (patch)
tree59f9222f0dd8dedfdd97f3aeeed651061c77d7aa /package.spec
parente8ee7815139beb9b5d9abd1986145a23c08674e4 (diff)
downloadopenSUSEConf2022-78c42d24842a9df57b0279a75a5d0d6544100d35.tar.gz
First version of the presentation
Diffstat (limited to 'package.spec')
-rw-r--r--package.spec44
1 files changed, 44 insertions, 0 deletions
diff --git a/package.spec b/package.spec
new file mode 100644
index 0000000..2be6e7f
--- /dev/null
+++ b/package.spec
@@ -0,0 +1,44 @@
+%{?!python_module:%define python_module() python-%{**} python3-%{**}}
+Name: python-foobar
+Version: 1.0.2
+Release: 0
+Summary: Example foobar package
+License: MIT
+URL: https://github.com/bumba/foobar
+Source: https://files.pythonhosted.org/packages/source/s/foobar/foobar-%{version}.zip
+# PATCH-FIX-UPSTREAM remove_mock.patch bsc#123456 mcepl@suse.com
+# we don't need stinking mock
+Patch0: remove_mock.patch
+BuildRequires: %{python_module appdirs}
+BuildRequires: %{python_module pytest}
+BuildRequires: fdupes
+BuildRequires: python-rpm-macros
+Requires: python-appdirs
+BuildArch: noarch
+%python_subpackages
+
+%description
+foobar is a collection of enhancements to the Python packages that
+allow you to build and distribute Python packages,
+
+%prep
+%autosetup -p1 -n foobar-%{version}
+
+%build
+%python_build
+
+%install
+%python_install
+%python_expand %fdupes %{buildroot}%{$python_sitelib}
+
+%check
+%pytest -k
+
+%files %{python_files}
+%license LICENSE
+%doc CHANGES.rst README.rst
+%{_bindir}/foobar
+%{python_sitelib}/foobar
+%{python_sitelib}/foobar-%{version}-py%{python_version}.egg-info
+
+%changelog