summaryrefslogtreecommitdiffstats
path: root/cgit.spec
diff options
context:
space:
mode:
Diffstat (limited to 'cgit.spec')
-rw-r--r--cgit.spec25
1 files changed, 24 insertions, 1 deletions
diff --git a/cgit.spec b/cgit.spec
index 26718af..c9d3917 100644
--- a/cgit.spec
+++ b/cgit.spec
@@ -22,7 +22,7 @@ make V=1 %{?_smp_mflags} \\\
Name: cgit
Version: 0.10.2
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A fast web interface for git
Group: Development/Tools
@@ -32,6 +32,7 @@ Source0: http://git.zx2c4.com/cgit/snapshot/%{name}-%{version}.tar.xz
Source1: http://www.kernel.org/pub/software/scm/git//git-%{gitver}.tar.xz
Source2: cgitrc
Source3: cgit.httpd
+Source4: README.SELinux
# On all but RHEL5 highlight is version 3.
%if 0%{?fedora} || 0%{?rhel} >= 6
Patch1: cgit-0.9.1-highlightv3.patch
@@ -67,6 +68,25 @@ rm -rf git
mv git-%{gitver} git
sed -i 's/^\(CFLAGS = \).*/\1%{optflags}/' git/Makefile
+# I tried to use matchpathcon, but we would need to require
+# selinux-policy-targeted probably.
+
+build_dist=%{?fedora:fedora}%{?rhel:rhel}
+build_ver=%{?fedora}%{?rhel}
+
+cgit_context=git_content_t
+case "$build_dist-$build_ver" in
+ fedora-19|fedora-20|rhel-6|rhel-7)
+ cgit_context=httpd_git_content_t
+ ;;
+ rhel-5|-)
+ cgit_context=httpd_sys_content_t
+ ;;
+esac
+
+sed -e "s|@CGIT_CONTEXT@|$cgit_context|g" \
+ %{SOURCE4} > README.SELinux
+
%build
%{make_cgit}
@@ -105,6 +125,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Jul 07 2014 Pavel Raiskup <praiskup@redhat.com> - 0.10.2-2
+- install README.SELinux documentation again (#1036123)
+
* Tue Jul 01 2014 Kevin Fenzi <kevin@scrye.com> 0.10.2-1
- Update to 0.10.2. Fixes bug #1114970