aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c6ebb95c..9ad4bb75 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,9 @@ from sos import __version__ as VERSION
setup(
name='sos',
version=VERSION,
- install_requires=['pexpect', 'pyyaml'],
+ # to avoid a packaging dependency on older RHELs
+ # we only declare it on recent Python versions
+ install_requires=['pexpect', 'pyyaml', 'packaging;python_version>="3.11"'],
description=(
'A set of tools to gather troubleshooting information from a system'
),