aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorMiro Hrončok <miro@hroncok.cz>2023-10-27 14:42:52 +0200
committerJake Hunsaker <jacob.r.hunsaker@gmail.com>2023-10-28 13:43:47 -0700
commitaafb03e83af45fc725d57736019cec36b352f34e (patch)
treee8185386e336938a5c63ada18db15f6bc191890c /setup.py
parentf2261a493162f7499cc1758039f8bbf48e20906f (diff)
downloadsos-aafb03e83af45fc725d57736019cec36b352f34e.tar.gz
[build] Actually indicate this requires packaging
This is a followup for 56904018045fdbdad666e55f0a850bc365809e50 I hereby declare that you can do whatever you want with this commit: Signed-off-by: Miro Hrončok <miro@hroncok.cz>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 3 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index c6ebb95c..9ad4bb75 100644
--- a/setup.py
+++ b/setup.py
@@ -7,7 +7,9 @@ from sos import __version__ as VERSION
setup(
name='sos',
version=VERSION,
- install_requires=['pexpect', 'pyyaml'],
+ # to avoid a packaging dependency on older RHELs
+ # we only declare it on recent Python versions
+ install_requires=['pexpect', 'pyyaml', 'packaging;python_version>="3.11"'],
description=(
'A set of tools to gather troubleshooting information from a system'
),