diff options
author | Jake Hunsaker <jhunsake@redhat.com> | 2020-07-03 10:19:13 -0400 |
---|---|---|
committer | Bryan Quigley <code@bryanquigley.com> | 2020-07-27 16:35:13 -0700 |
commit | fe8c80016d9e8a13130fe2c97840999930453ee8 (patch) | |
tree | 96f178e877df943f501302a1e5c1fbeee9cce2c4 /setup.py | |
parent | 5d6c5d5d4dd231fc52d3fc245019c0a4d00d6339 (diff) | |
download | sos-fe8c80016d9e8a13130fe2c97840999930453ee8.tar.gz |
[build] Update specfile and setuptools
Updates the specfile for 4.0, specifically supporting py3 builds in
conjunction with setuptools.
Closes: #307
Resolves: #2160
Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 44 |
1 files changed, 26 insertions, 18 deletions
@@ -58,27 +58,35 @@ class InstallData(install_data): return (out+".gz", _) return (out, _) -setup(name='sos', - version=VERSION, - description=("""A set of tools to gather troubleshooting""" - """ information from a system."""), - author='Bryn M. Reeves', - author_email='bmr@redhat.com', - maintainer='Jake Hunsaker', - maintainer_email='jhunsake@redhat.com', - url='https://github.com/sosreport/sos', - license="GPLv2+", - scripts=['bin/sos', 'bin/sosreport'], - data_files=[ +setup( + name='sos', + version=VERSION, + description=("""A set of tools to gather troubleshooting""" + """ information from a system."""), + author='Bryn M. Reeves', + author_email='bmr@redhat.com', + maintainer='Jake Hunsaker', + maintainer_email='jhunsake@redhat.com', + url='https://github.com/sosreport/sos', + license="GPLv2+", + scripts=['bin/sos', 'bin/sosreport', 'bin/sos-collector'], + data_files=[ + ('/', ['sos.conf']), ('share/man/man1', ['man/en/sosreport.1', 'man/en/sos-report.1', 'man/en/sos.1', 'man/en/sos-collect.1', - 'man/en/sos-collector.1']), + 'man/en/sos-collector.1', 'man/en/sos-clean.1', + 'man/en/sos-mask.1']), ('share/man/man5', ['man/en/sos.conf.5']), - ], - packages=['sos', 'sos.policies', 'sos.report', 'sos.report.plugins', - 'sos.collector', 'sos.collector.clusters'], - cmdclass={'build': BuildData, 'install_data': InstallData}, - requires=['pexpect'] + ('share/licenses/sos', ['LICENSE']), + ('share/doc/sos', ['AUTHORS', 'README.md']) + ], + packages=[ + 'sos', 'sos.policies', 'sos.report', 'sos.report.plugins', + 'sos.collector', 'sos.collector.clusters', 'sos.cleaner', + 'sos.cleaner.mappings', 'sos.cleaner.parsers' + ], + cmdclass={'build': BuildData, 'install_data': InstallData}, + requires=['pexpect'] ) |