aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJake Hunsaker <jhunsake@redhat.com>2021-02-03 11:29:14 -0500
committerJake Hunsaker <jhunsake@redhat.com>2021-02-03 12:26:56 -0500
commitf9db680ec67de3e97aaa233ffccdf4ccdb5ad307 (patch)
tree70e887c67967bbe0a52966d3f1cc7855505add20 /setup.py
parent011efb7bdea524407b856bd70bc772b99a3f29bc (diff)
downloadsos-f9db680ec67de3e97aaa233ffccdf4ccdb5ad307.tar.gz
[build] Add the new presets module to setup.py
When presets were split out from policies, they were not added to `setup.py` in the list of packages. As such they would not be included in any builds that relied upon using `setup.py` to generate a source tarball. Add those packages to the list so that they may be included. Closes: #2390 Resolves: #2402 Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py3
1 files changed, 2 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 1003c22d..1e8d8e2d 100644
--- a/setup.py
+++ b/setup.py
@@ -97,7 +97,8 @@ setup(
('config', ['sos.conf'])
],
packages=[
- 'sos', 'sos.policies', 'sos.policies.distros', 'sos.policies.runtimes',
+ 'sos', 'sos.presets', 'sos.presets.redhat', 'sos.policies',
+ 'sos.policies.distros', 'sos.policies.runtimes',
'sos.policies.package_managers', 'sos.policies.init_systems',
'sos.report', 'sos.report.plugins', 'sos.collector',
'sos.collector.clusters', 'sos.cleaner', 'sos.cleaner.mappings',