aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorastokes <astokes@ef72aa8b-4018-0410-8976-d6e080ef94d8>2010-03-26 18:16:24 +0000
committerastokes <astokes@ef72aa8b-4018-0410-8976-d6e080ef94d8>2010-03-26 18:16:24 +0000
commitf398a5a7cdfc1e7c3fe52676603c0bf0cd711eb6 (patch)
tree37525023e2dce4ee93680825ff56785384542b6e /setup.py
parent3422e6d25ae6de598c40973c6ed5258641bb53b6 (diff)
downloadsos-f398a5a7cdfc1e7c3fe52676603c0bf0cd711eb6.tar.gz
updates
git-svn-id: svn+ssh://svn.fedorahosted.org/svn/sos/trunk@871 ef72aa8b-4018-0410-8976-d6e080ef94d8
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py9
1 files changed, 5 insertions, 4 deletions
diff --git a/setup.py b/setup.py
index 8806ee4d..d90dfedb 100644
--- a/setup.py
+++ b/setup.py
@@ -18,7 +18,7 @@ builddir = None
data_files = [ ('/etc', [ 'sos.conf']),
('share/sos/', ['gpgkeys/rhsupport.pub']),
- ('share/man/man1', ['sosreport.1'])]
+ ('share/man/man1', ['man/en/sosreport.1'])]
class refresh_translations(Command):
@@ -81,7 +81,7 @@ class install(_install):
locale = self.install_base + "/share/locale"
class install_lib(_install_lib):
- """ custom install_lib command to place locale/docs location into library"""
+ """ custom install_lib command to place locale location into library"""
def run(self):
for initfile in [ "sos/__init__.py" ]:
@@ -103,7 +103,7 @@ class install_data(_install_data):
print "Installing %s to %s" % (src_path, install_path)
toadd = (install_path, [src_path])
# Add these to the datafiles list
- datafiles.append(toadd)
+ data_files.append(toadd)
class TestBaseCommand(Command):
user_options = []
@@ -133,7 +133,7 @@ class TestSOS(TestBaseCommand):
def initialize_options(self):
TestBaseCommand.initialize_options(self)
- test.testfile = None
+ self.testfile = None
def finalize_options(self):
TestBaseCommand.finalize_options(self)
@@ -160,6 +160,7 @@ setup(
url = 'http://fedorahosted.org/sos',
description = 'SOS - son of sysreport',
packages = ['sos'],
+ scripts = ["sosreport"],
data_files = data_files,
cmdclass = {
'test': TestSOS,