aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJake Hunsaker <jhunsake@redhat.com>2022-04-20 11:19:30 -0400
committerJake Hunsaker <jhunsake@redhat.com>2022-05-09 11:21:16 -0400
commit8aec430fd27785aa85a6e677151a2bb76da244dc (patch)
treef6b857846f1794b68ea0e244c4b3092bb4cddee3 /setup.py
parent9b10abcdd4aaa41e2549438d5bc52ece86dcb21f (diff)
downloadsos-8aec430fd27785aa85a6e677151a2bb76da244dc.tar.gz
[collect] Add cluster profile for RHOSP
Adds a cluster profile for Red Hat OpenStack Platform to identify controller and (optionally) compute nodes to collect sos reports from. Note that this adds a dependency on pyyaml to sos. This should be considered a weak dependency by downstreams. As such, it is added as a 'Recommends' in `sos.spec`. pip does not have the concept of 'weak dependencies', and so is added as a regular requirement in `setup.py`. Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5c1fa318..2a70802d 100644
--- a/setup.py
+++ b/setup.py
@@ -107,7 +107,7 @@ setup(
],
cmdclass=cmdclass,
command_options=command_options,
- requires=['pexpect', 'python_magic']
+ requires=['pexpect', 'python_magic', 'pyyaml']
)