aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJake Hunsaker <jhunsake@redhat.com>2021-09-10 13:38:19 -0400
committerJake Hunsaker <jhunsake@redhat.com>2021-09-27 10:20:12 -0400
commit676dfca09d9c783311a51a1c53fa0f7ecd95bd28 (patch)
tree948afd7edc6db1686f8774fcf5dd57c42edd1c1a /setup.py
parente76c69264908aea96df30be134e0f5afa64bd1ea (diff)
downloadsos-676dfca09d9c783311a51a1c53fa0f7ecd95bd28.tar.gz
[collect] Abstract transport protocol from SoSNode
Since its addition to sos, collect has assumed the use of a system installation of SSH in order to connect to the nodes identified for collection. However, there may be use cases and desires to use other transport protocols. As such, provide an abstraction for these protocols in the form of the new `RemoteTransport` class that `SoSNode` will now leverage. So far an abstraction for the currently used SSH ControlPersist function is provided, along with a psuedo abstraction for local execution so that SoSNode does not directly need to make more "if local then foo" checks than are absolutely necessary. Related: #2668 Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 7653b59d..25e87a71 100644
--- a/setup.py
+++ b/setup.py
@@ -101,8 +101,8 @@ setup(
'sos.policies.distros', 'sos.policies.runtimes',
'sos.policies.package_managers', 'sos.policies.init_systems',
'sos.report', 'sos.report.plugins', 'sos.collector',
- 'sos.collector.clusters', 'sos.cleaner', 'sos.cleaner.mappings',
- 'sos.cleaner.parsers', 'sos.cleaner.archives'
+ 'sos.collector.clusters', 'sos.collector.transports', 'sos.cleaner',
+ 'sos.cleaner.mappings', 'sos.cleaner.parsers', 'sos.cleaner.archives'
],
cmdclass=cmdclass,
command_options=command_options,