aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJake Hunsaker <jhunsake@redhat.com>2020-04-08 11:17:50 -0400
committerJake Hunsaker <jhunsake@redhat.com>2020-04-08 11:28:39 -0400
commit6738ca63a1eab4381e436b7f5d5e0e0cc0d51953 (patch)
tree58727963242dd1cf11fbc5a8b336fabfbc504252 /setup.py
parentb0a3b9f07c49ccc58378e41618646e626679582f (diff)
downloadsos-6738ca63a1eab4381e436b7f5d5e0e0cc0d51953.tar.gz
[build] Update setuptools for new package layout, remove python2 tests
Updates setup.py to reflect project changes with 4.0, thus allowing the 'python setup.py install' checks to run normally. Removes futures from requirements.txt, as futures is packaged with python 3.4 and newer, and sos no longer supports python2. In that vein, also removes the pytohn-2.7 test from the travis configuration. Resolves: #2004 Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py6
1 files changed, 4 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index affe7311..6eab75a8 100644
--- a/setup.py
+++ b/setup.py
@@ -64,14 +64,16 @@ setup(name='sos',
""" information from a system."""),
author='Bryn M. Reeves',
author_email='bmr@redhat.com',
+ maintainer='Jake Hunsaker',
+ maintainer_email='jhunsake@redhat.com',
url='https://github.com/sosreport/sos',
license="GPLv2+",
- scripts=['sosreport'],
+ scripts=['bin/sos', 'bin/sosreport'],
data_files=[
('share/man/man1', ['man/en/sosreport.1']),
('share/man/man5', ['man/en/sos.conf.5']),
],
- packages=['sos', 'sos.plugins', 'sos.policies'],
+ packages=['sos', 'sos.report.plugins', 'sos.policies', 'sos.report'],
cmdclass={'build': BuildData, 'install_data': InstallData},
requires=['six', 'futures'],
)