aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorJake Hunsaker <jhunsake@redhat.com>2020-07-29 10:02:23 -0400
committerBryan Quigley <code@bryanquigley.com>2020-07-29 13:09:19 -0700
commit115881b6c761ada944ce043ce91f5e5cb2a8cb11 (patch)
tree17b19790a21f8f39f3cf7c7c0f40e0bd4d54f5e5 /setup.py
parent7644b6d9865049f4ee99dfe1507f63200c520677 (diff)
downloadsos-115881b6c761ada944ce043ce91f5e5cb2a8cb11.tar.gz
[build] Remove sos.conf from setup.py, make config file optional
In the recent packaging update (#2160), sos.conf was added to `setup.py` to include it in the source distribution tarball produced. That was the wrong approach, as setuptools explicitly tries to prevent files from being written outside of the package directory. Instead, the correct approach is to make the config file effectively optional, by producing a warning message when it doesn't exist, but still continue on with the defaults rather than aborting. Note that parsing errors and duplicate entries will still cause sos to abort execution. Resolves: #2174 Signed-off-by: Jake Hunsaker <jhunsake@redhat.com> Signed-off-by: Bryan Quigley <code@bryanquigley.com>
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py1
1 files changed, 0 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 04ee66a6..85d426ba 100644
--- a/setup.py
+++ b/setup.py
@@ -71,7 +71,6 @@ setup(
license="GPLv2+",
scripts=['bin/sos', 'bin/sosreport', 'bin/sos-collector'],
data_files=[
- ('/', ['sos.conf']),
('share/man/man1', ['man/en/sosreport.1', 'man/en/sos-report.1',
'man/en/sos.1', 'man/en/sos-collect.1',
'man/en/sos-collector.1', 'man/en/sos-clean.1',