diff options
author | Jake Hunsaker <jhunsake@redhat.com> | 2022-03-30 12:51:06 -0400 |
---|---|---|
committer | Jake Hunsaker <jhunsake@redhat.com> | 2022-04-12 13:53:32 -0400 |
commit | 0689d8b3e10e969b7fed0af9ac906222858e4fb9 (patch) | |
tree | 6c5b86db1582961ab479b3505b82c81c58d956a6 /setup.py | |
parent | d64988edd297a555a8482f98d7bd5b411fa582cd (diff) | |
download | sos-0689d8b3e10e969b7fed0af9ac906222858e4fb9.tar.gz |
[utilities] Better detect binary files with python3-magic
Adds a new `file_is_binary()` method to `sos.utilities` to serve as a
single point to determine if a file is binary or not, relying on the
python3-magic module.
Closes: #2839
Signed-off-by: Jake Hunsaker <jhunsake@redhat.com>
Diffstat (limited to 'setup.py')
-rw-r--r-- | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -107,7 +107,7 @@ setup( ], cmdclass=cmdclass, command_options=command_options, - requires=['pexpect'] + requires=['pexpect', 'python_magic'] ) |