aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorAdam Stokes <adam.stokes@ubuntu.com>2013-07-26 10:48:56 -0400
committerAdam Stokes <adam.stokes@ubuntu.com>2013-07-26 10:48:56 -0400
commitde0b58ac472837b2e75729e00827117072a83893 (patch)
tree465fafd9c76e8a6dcae9be4fb0b7801303a33521 /debian
parentf499e561043af2f801deb48fdc91d51a29ba22e8 (diff)
downloadsos-de0b58ac472837b2e75729e00827117072a83893.tar.gz
Add support for distutils
- We are planning on moving to python distutils for future packaging however, we still want to keep our current build infrastructure around until we are able to test the builds overtime. For now distutils will live alongside the current build process and slowly replace the Makefiles once deemed fit. Signed-off-by: Adam Stokes <adam.stokes@ubuntu.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/docs1
-rw-r--r--debian/install1
-rw-r--r--debian/pkg.pyinstall1
-rwxr-xr-xdebian/rules15
-rw-r--r--debian/sosreport.links1
5 files changed, 17 insertions, 2 deletions
diff --git a/debian/docs b/debian/docs
new file mode 100644
index 00000000..475d728a
--- /dev/null
+++ b/debian/docs
@@ -0,0 +1 @@
+README.md AUTHORS
diff --git a/debian/install b/debian/install
new file mode 100644
index 00000000..6c41a24d
--- /dev/null
+++ b/debian/install
@@ -0,0 +1 @@
+sos.conf etc/
diff --git a/debian/pkg.pyinstall b/debian/pkg.pyinstall
deleted file mode 100644
index 8b68fc88..00000000
--- a/debian/pkg.pyinstall
+++ /dev/null
@@ -1 +0,0 @@
-sos/* /usr/share/sosreport/
diff --git a/debian/rules b/debian/rules
index 15b7f5ec..90637142 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,4 +5,17 @@ DH_ALWAYS_EXCLUDE=.git
%:
dh $@ --with python2
-override_dh_auto_test:
+override_dh_auto_install:
+ python setup.py \
+ install \
+ --install-lib=usr/share/sosreport/ \
+ --install-data=usr/ \
+ --install-scripts=usr/share/sosreport/ \
+ --root=$(CURDIR)/debian/sosreport/ \
+ --no-compile -O0
+
+override_dh_clean:
+ rm -rf build/
+ rm -rf dist/
+ find . -name '*.pyc' -delete
+
diff --git a/debian/sosreport.links b/debian/sosreport.links
new file mode 100644
index 00000000..04d91625
--- /dev/null
+++ b/debian/sosreport.links
@@ -0,0 +1 @@
+/usr/share/sosreport/sosreport /usr/bin/sosreport