aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorJesse Jaggars <jjaggars@redhat.com>2012-03-05 11:38:43 -0600
committerJesse Jaggars <jjaggars@redhat.com>2012-03-05 11:38:43 -0600
commitc69987bf6d2c0de8c345a8a79410212116f8098b (patch)
tree6536b9e5e52bd3dc3a61e523946796cbcc2bda78 /debian
parentc10115652a795d0c7971ec9b03c4c58742063ddf (diff)
downloadsos-c69987bf6d2c0de8c345a8a79410212116f8098b.tar.gz
Refactoring DebianPackageManager to use the superclass
Squashed commit of the following: commit 4973246ac9ade11bbaf113985a1410939ca3ccf5 Author: Adam Stokes <hackr@cypherbook.com> Date: Mon Mar 5 00:15:00 2012 -0500 packaging: Fix install perms within our python package directory and update packaging to use support dh_python2 helper. During installation of plugins/policies we were giving additional rwx bits to those files. This addresses some complaints from debian's rpmlint equivalent lintian. Also updated the build rules to support dh_python2 rather than deprecated dh_pysupport. Signed-off-by: Jesse Jaggars <jjaggars@redhat.com> commit 986981941e058afb593baaba676b2aef0e6e1147 Author: Adam Stokes <hackr@cypherbook.com> Date: Sun Mar 4 23:19:56 2012 -0500 ubuntu.template: set passphrase so anyone referencing will know its an example. Signed-off-by: Jesse Jaggars <jjaggars@redhat.com> commit 809bdc150a5e2456d3ee87c34c06eaa002edf43c Author: Adam Stokes <hackr@cypherbook.com> Date: Sun Mar 4 23:11:33 2012 -0500 Makefile: generic name for build dir, fix failure during make install and GPG configurable. First, changed build dir from rpm-build to dist-build to keep things more general. Second, Makefile was not updated to reflect recent housecleaning wrt removing TODO file Finaly, added ability use optional gpg templates during build phase Signed-off-by: Jesse Jaggars <jjaggars@redhat.com> commit 61d583d7eb913402f4200b5ece7ad2732cafd716 Author: Adam Stokes <hackr@cypherbook.com> Date: Sun Mar 4 23:09:11 2012 -0500 debian/rules: Do not run dh_auto_test by default For systems which do not contain previously installed sosreport the test suite will fail due to not being able to find the sos python package. Signed-off-by: Jesse Jaggars <jjaggars@redhat.com> commit a8950a892a905575da0993785623946ea8276075 Author: Adam Stokes <hackr@cypherbook.com> Date: Sun Mar 4 23:02:24 2012 -0500 sos/policies/debian: do not use a list with shell_out routine when listing packages. A recent bug was previously found wrt shell_out not accepting a list of commands/parameters. This policy is updated to run the routine appropriately. Signed-off-by: Jesse Jaggars <jjaggars@redhat.com> commit 6b2300ee8bb121042f3dac91411773a8c788f6b8 Author: Adam Stokes <hackr@cypherbook.com> Date: Sun Mar 4 22:46:33 2012 -0500 debian/control: Make package name consistent with other distros Debian/Ubuntu was set with a package name sosreport which isn't the package name during builds on RHEL/Fedora. Signed-off-by: Jesse Jaggars <jjaggars@redhat.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog2
-rw-r--r--debian/control4
-rw-r--r--debian/pkg.pyinstall1
-rwxr-xr-xdebian/rules6
4 files changed, 10 insertions, 3 deletions
diff --git a/debian/changelog b/debian/changelog
index a788b652..a70f2c54 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,4 +1,4 @@
-sosreport (2.3) unstable; urgency=low
+sos (2.3) unstable; urgency=low
* Initial release.
diff --git a/debian/control b/debian/control
index 1625c69e..1e0f4f42 100644
--- a/debian/control
+++ b/debian/control
@@ -1,11 +1,11 @@
-Source: sosreport
+Source: sos
Maintainer: Adam Stokes <adam.stokes@canonical.com>
Section: python
Priority: optional
Standards-Version: 3.9.2
Build-Depends: debhelper (>= 8), python-support, python (>=2.7), gettext
-Package: sosreport
+Package: sos
Architecture: any
Depends: ${python:Depends}, ${misc:Depends}
Description: A set of tools to gather troubleshooting information from a system
diff --git a/debian/pkg.pyinstall b/debian/pkg.pyinstall
new file mode 100644
index 00000000..b7005d31
--- /dev/null
+++ b/debian/pkg.pyinstall
@@ -0,0 +1 @@
+sos/* /usr/share/pyshared/sos/
diff --git a/debian/rules b/debian/rules
index 3e0dfd04..d1b7c05f 100755
--- a/debian/rules
+++ b/debian/rules
@@ -5,3 +5,9 @@ DH_ALWAYS_EXCLUDE=.git
%:
dh $@
+override_dh_pysupport:
+ dh_python2 -p sos
+override_dh_fixperms:
+ dh_fixperms -Xsos
+override_dh_auto_test:
+