aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorAdam Stokes <adam.stokes@canonical.com>2012-02-21 01:38:53 +0000
committerAdam Stokes <adam.stokes@canonical.com>2012-02-21 01:38:53 +0000
commit6c21132ceb2a1a5d879b48efcefbf163767e94ec (patch)
tree59a314c095bc1574840f48e4535af43289d42106 /debian
parentdfa1fc0d77f46a373e85a19448403da95faa27a9 (diff)
downloadsos-6c21132ceb2a1a5d879b48efcefbf163767e94ec.tar.gz
debian: Add packaging rules for Debian/Ubuntu
Signed-off-by: Adam Stokes <adam.stokes@canonical.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog5
-rw-r--r--debian/compat1
-rw-r--r--debian/control15
-rw-r--r--debian/copyright0
-rw-r--r--debian/pyversions1
-rwxr-xr-xdebian/rules7
6 files changed, 29 insertions, 0 deletions
diff --git a/debian/changelog b/debian/changelog
new file mode 100644
index 00000000..a788b652
--- /dev/null
+++ b/debian/changelog
@@ -0,0 +1,5 @@
+sosreport (2.3) unstable; urgency=low
+
+ * Initial release.
+
+ -- Adam Stokes <adam.stokes@canonical.com> Mon, 20 Feb 2012 16:41:39 +0000
diff --git a/debian/compat b/debian/compat
new file mode 100644
index 00000000..45a4fb75
--- /dev/null
+++ b/debian/compat
@@ -0,0 +1 @@
+8
diff --git a/debian/control b/debian/control
new file mode 100644
index 00000000..1625c69e
--- /dev/null
+++ b/debian/control
@@ -0,0 +1,15 @@
+Source: sosreport
+Maintainer: Adam Stokes <adam.stokes@canonical.com>
+Section: python
+Priority: optional
+Standards-Version: 3.9.2
+Build-Depends: debhelper (>= 8), python-support, python (>=2.7), gettext
+
+Package: sosreport
+Architecture: any
+Depends: ${python:Depends}, ${misc:Depends}
+Description: A set of tools to gather troubleshooting information from a system
+ Sos is a set of tools that gathers information about system
+ hardware and configuration. The information can then be used for
+ diagnostic purposes and debugging. Sos is commonly used to help
+ support technicians and developers.
diff --git a/debian/copyright b/debian/copyright
new file mode 100644
index 00000000..e69de29b
--- /dev/null
+++ b/debian/copyright
diff --git a/debian/pyversions b/debian/pyversions
new file mode 100644
index 00000000..3ad2293e
--- /dev/null
+++ b/debian/pyversions
@@ -0,0 +1 @@
+2.7-
diff --git a/debian/rules b/debian/rules
new file mode 100755
index 00000000..3e0dfd04
--- /dev/null
+++ b/debian/rules
@@ -0,0 +1,7 @@
+#!/usr/bin/make -f
+
+DH_ALWAYS_EXCLUDE=.git
+
+%:
+ dh $@
+