aboutsummaryrefslogtreecommitdiffstats
path: root/debian
diff options
context:
space:
mode:
authorAdam Stokes <adam.stokes@ubuntu.com>2014-01-15 22:23:32 -0500
committerAdam Stokes <adam.stokes@ubuntu.com>2014-01-15 22:23:32 -0500
commit55b48fa4c5e625c74b1ffd80213b3cd72809365a (patch)
tree22c4c0f49ce670b08331b9e7d3a87de11f4a8f23 /debian
parentfac1f1fc6f8bc85868aa9f97584bd865add3204b (diff)
downloadsos-55b48fa4c5e625c74b1ffd80213b3cd72809365a.tar.gz
Update debian packaging to use pybuild and prep for 3.1 release.
Signed-off-by: Adam Stokes <adam.stokes@ubuntu.com>
Diffstat (limited to 'debian')
-rw-r--r--debian/changelog14
-rw-r--r--debian/control4
-rwxr-xr-xdebian/rules18
3 files changed, 21 insertions, 15 deletions
diff --git a/debian/changelog b/debian/changelog
index 109b5e2a..96c16e51 100644
--- a/debian/changelog
+++ b/debian/changelog
@@ -1,3 +1,17 @@
+sosreport (3.1-1) unstable; urgency=low
+
+ * New upstream release v3.1
+ Features include:
+ - Full Python 3 support
+ - Further modularized openstack plugins
+ * debian/rules:
+ - Use pybuild
+ * debian/control:
+ - Use X-Python-Version: >= 3.3
+ - This drops support for Python 2 as we move forward.
+
+ -- Adam Stokes <adam.stokes@ubuntu.com> Wed, 15 Jan 2014 16:58:54 -0500
+
sosreport (3.0-1) unstable; urgency=low
* New upstream release v3.0
diff --git a/debian/control b/debian/control
index 23742950..9d2b0532 100644
--- a/debian/control
+++ b/debian/control
@@ -3,9 +3,9 @@ Maintainer: Adam Stokes <adam.stokes@ubuntu.com>
Section: admin
Priority: optional
Standards-Version: 3.9.4
-Build-Depends: debhelper (>= 9), python3 (>=3.3), gettext, python3-nose, python3-six
+Build-Depends: debhelper (>= 9), dh-python, python3-all, gettext, python3-nose, python3-six
Homepage: https://github.com/sosreport/sosreport
-XS-Python3-Version: 3.3
+X-Python3-Version: >= 3.3
Package: sosreport
Architecture: any
diff --git a/debian/rules b/debian/rules
index 4b200a0d..07e7196d 100755
--- a/debian/rules
+++ b/debian/rules
@@ -1,21 +1,13 @@
#!/usr/bin/make -f
DH_ALWAYS_EXCLUDE=.git
-
-%:
- dh $@ --with python3
-
-override_dh_auto_install:
- python setup.py \
- install \
- --install-lib=usr/share/sosreport/ \
+export PYBUILD_NAME=sosreport
+export PYBUILD_DISABLE_python2=1
+export PYBUILD_INSTALL_ARGS_python3=--install-lib=usr/share/sosreport/ \
--install-data=usr/ \
--install-scripts=usr/share/sosreport/ \
--root=$(CURDIR)/debian/sosreport/ \
--no-compile -O0
-override_dh_clean:
- rm -rf build/
- rm -rf dist/
- find . -name '*.pyc' -delete
-
+%:
+ dh $@ --with python3 --buildsystem=pybuild