summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@suse.de>2005-09-17 23:58:48 +0000
committerAndreas Gruenbacher <agruen@suse.de>2005-09-17 23:58:48 +0000
commite090875775b059b97d41f6e213d12d790ce85e25 (patch)
treeba680a6169477a0cd0c9ac097f181572dc2611b5 /configure.ac
parent8e965d1593d220b945d0dca601d4cfd848f79c83 (diff)
downloadquilt-e090875775b059b97d41f6e213d12d790ce85e25.tar.gz
- configure.ac: fail if getopt does not support --long.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac13
1 files changed, 8 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 2d71f58..3e2c40b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.42],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.42 $)
+AC_REVISION ($Revision: 1.43 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -73,12 +73,15 @@ if test -n "$GETOPT"; then
$GETOPT -o t --long test -- --test | grep -qe '^ *--test *--'
getopt_long_works=$?
if test $getopt_long_errors -eq 1 -a $getopt_long_works -eq 0; then
- getopt_long_syntax=yes
AC_MSG_RESULT(yes)
else
- getopt_long_syntax=no
- AC_MSG_WARN(no)
- GETOPT=''
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+$GETOPT does not support the --long option.
+If you don't have a version of getopt that supports long options, you
+can specify '--with-getopt=none' and $PACKAGE_NAME will use its own
+internal getopt.
+])
fi
fi