summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <jdelvare@suse.de>2012-02-01 18:08:49 +0100
committerJean Delvare <jdelvare@suse.de>2012-02-01 18:08:49 +0100
commit94e2ecad7c47cddbd719d774861947bf726c7a4e (patch)
treed7656d3ed797b55a3c99db655230b7fce53dedf7 /configure.ac
parent3f25ce18333a8afe81ce8968f756ba986bd9b4b5 (diff)
downloadquilt-94e2ecad7c47cddbd719d774861947bf726c7a4e.tar.gz
Clean up legacy C code
Finally get rid of the old C implementation of backup-files, together with all the related checks in configure and variables in Makefile. Signed-off-by: Jean Delvare <jdelvare@suse.de>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac25
1 files changed, 0 insertions, 25 deletions
diff --git a/configure.ac b/configure.ac
index 2d1d10a..6496e64 100644
--- a/configure.ac
+++ b/configure.ac
@@ -8,25 +8,6 @@ PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
AC_SUBST(PACKAGE_TARNAME)
-dnl Setup for backup-files compilation
-AC_HEADER_STDC
-AC_CHECK_FUNCS([fchmod chmod])
-AC_CHECK_FUNCS([mkstemp mktemp], break)
-AC_CHECK_FUNCS([mkdir rmdir])
-AC_CHECK_FUNCS([strchr strrchr])
-AC_CHECK_FUNCS([strerror])
-AC_C_CONST
-AC_FUNC_STAT
-
-#AC_CONFIG_LIBOBJ_DIR(lib)
-#AC_REPLACE_FUNCS()
-
-if test "$ac_compiler_gnu" = "yes"; then
- CFLAGS="$CFLAGS -Wall"
-fi
-EXEEXT="$ac_cv_exeext"
-AC_SUBST(EXEEXT)
-
AC_PROG_INSTALL
AC_SYS_INTERPRETER
@@ -411,11 +392,5 @@ AC_MSG_RESULT([$PACKAGE_NAME version $PACKAGE_VERSION configured.])
AC_MSG_RESULT([])
AC_MSG_RESULT([Using '$prefix' for installation prefix.])
-# we don't need to see this just for the backup-files command
-# but we may as well spec it for the future
-#AC_MSG_RESULT([Using '$CC' for C compiler.])
-#AC_MSG_RESULT([Building with '$CFLAGS' for C compiler flags.])
-#AC_MSG_RESULT([Building with '$LIBS' for linker flags.])
-
AC_MSG_RESULT([])
AC_MSG_RESULT([Report bugs to $PACKAGE_BUGREPORT])