summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorJean Delvare <khali@linux-fr.org>2005-09-20 18:07:45 +0000
committerJean Delvare <khali@linux-fr.org>2005-09-20 18:07:45 +0000
commit40e41fc6675c87eff274cb49c5e517ce24815a3c (patch)
tree93872fb6e3f340cc6d58820268c0d08b3d36e8a5 /configure.ac
parentf6ce6f76fba5c064e52395e029caba6c26b32fa0 (diff)
downloadquilt-40e41fc6675c87eff274cb49c5e517ce24815a3c.tar.gz
- Makefile.in: Fix compat/tail symlink creation. Fix variable exporting
bashism. - configure.ac: Use grep >/dev/null instead of grep -q for compatibility. Test for grep -q, some quilt scripts need it. - test/Makefile: Fix varible exporting and script sourcing bashisms.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac24
1 files changed, 19 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index ce91341..6a0c793 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.42],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.56 $)
+AC_REVISION ($Revision: 1.57 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -55,6 +55,20 @@ fi
QUILT_COMPAT_PROG_PATH(PERL, perl, [perl perl5])
QUILT_COMPAT_PROG_PATH(GREP, grep)
+
+AC_MSG_CHECKING([whether $GREP -q works])
+if echo first | $GREP -q first 2>/dev/null; then
+ AC_MSG_RESULT(yes)
+else
+ AC_MSG_RESULT(no)
+ AC_MSG_ERROR([
+Sorry, you have a version of grep which doesn't understand -q.
+$PACKAGE_NAME needs it. If you have access to a version of grep which does
+understand -q, you can supply its path with the '--with-grep=' option.
+Solaris users can use /usr/xpg4/bin/grep.
+])
+fi
+
QUILT_COMPAT_PROG_PATH(TAIL, tail)
# Solaris' /usr/bin/tail doesn't understand -n.
@@ -80,9 +94,9 @@ QUILT_COMPAT_PROG_PATH(GETOPT, getopt)
if test -z "$INTERNAL_GETOPT"; then
AC_MSG_CHECKING(for getopt --long syntax)
dnl check GNU syntax
- $GETOPT -o t --long test -- --test | grep -q 'illegal option'
+ $GETOPT -o t --long test -- --test | grep 'illegal option' >/dev/null
getopt_long_errors=$?
- $GETOPT -o t --long test -- --test | grep -q '^ *--test *--'
+ $GETOPT -o t --long test -- --test | grep '^ *--test *--' >/dev/null
getopt_long_works=$?
if test $getopt_long_errors -eq 1 -a $getopt_long_works -eq 0; then
AC_MSG_RESULT(yes)
@@ -120,7 +134,7 @@ QUILT_COMPAT_PROG_PATH(PATCH, patch)
# Sun's patch is a mess, issue a warning. But we are going to continue with
# the build because you might just be lucky.
AC_MSG_CHECKING([whether $PATCH will work])
-if $PATCH -v 2>&1 | grep -q "Sun" >/dev/null 2>&1; then
+if $PATCH -v 2>&1 | grep "Sun" >/dev/null; then
AC_MSG_RESULT(no)
AC_MSG_WARN([
Sorry, you have a Sun version of patch which is notoriously buggy. $PACKAGE_NAME
@@ -128,7 +142,7 @@ may function correctly, or minor errors may occur due to Sun's patch tool.
Please consider upgrading to GNU patch, if you already have GNU patch then you
can supply its path with the '--with-patch=' option.
])
-elif $PATCH --version 2>&1 | grep -q "patch 2.0" >/dev/null 2>&1; then
+elif $PATCH --version 2>&1 | grep "patch 2.0" >/dev/null; then
AC_MSG_RESULT(no)
AC_MSG_WARN([
Sorry, the version of patch you are using can cause severe problems when a patch