summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorAndreas Gruenbacher <agruen@suse.de>2007-04-19 23:13:35 +0000
committerAndreas Gruenbacher <agruen@suse.de>2007-04-19 23:13:35 +0000
commit2ad798ceff748d606aee047b3a418899a628dbe6 (patch)
tree1bd3bf71430d06c95cb4cc21816ea0d4681abc72 /configure.ac
parent722016eed292df209c01bc1328c802a867650d6d (diff)
downloadquilt-2ad798ceff748d606aee047b3a418899a628dbe6.tar.gz
Make pod2man optional (./configure --without-pod2man).
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac17
1 files changed, 15 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index f6012c0..ba0056a 100644
--- a/configure.ac
+++ b/configure.ac
@@ -2,7 +2,7 @@ dnl Process this file with autoconf to produce a configure script.
AC_INIT([quilt],[0.46],[quilt-dev@nongnu.org])
AC_CONFIG_AUX_DIR(config)
AC_PREREQ(2.53)
-AC_REVISION ($Revision: 1.82 $)
+AC_REVISION ($Revision: 1.83 $)
PACKAGE_RELEASE=1
AC_SUBST(PACKAGE_RELEASE)
@@ -188,7 +188,20 @@ Solaris users can use /usr/xpg4/bin/awk.
])
fi
-QUILT_COMPAT_PROG_PATH(POD2MAN, pod2man)
+AC_ARG_WITH(pod2man, AC_HELP_STRING(
+ [--with-pod2man],
+ [name of the pod2man executable to use (use --without-pod2man to disable)]),
+ [
+ if test x"$withval" = xno; then
+ POD2MAN=
+ else
+ POD2MAN=$withval
+ fi],[
+ AC_PATH_PROG(POD2MAN, pod2man)
+ ]
+ )
+AC_SUBST(POD2MAN)
+
QUILT_COMPAT_PROG_PATH(COLUMN, column)
QUILT_COMPAT_PROG_PATH(GETOPT, getopt)