aboutsummaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg16
1 files changed, 11 insertions, 5 deletions
diff --git a/setup.cfg b/setup.cfg
index 97318ec..4204b45 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -2,10 +2,10 @@
name = git-deps
summary = automatically detect dependencies between git commits
author = Adam Spiers
-author-email = git@adamspiers.org
+author_email = git@adamspiers.org
license = GPL-2+
-home-page = https://github.com/aspiers/git-deps
-description-file = README.md
+home_page = https://github.com/aspiers/git-deps
+description_file = README.md
classifier =
Development Status :: 4 - Beta
Environment :: Console
@@ -27,11 +27,17 @@ console_scripts =
[files]
scripts =
bin/git-fixup
-packages =
- git_deps
data_files =
share/git_deps = share/gitfile-handler.desktop
+[options]
+packages =
+ git_deps
+
+[options.entry_points]
+console_scripts =
+ git-deps = git_deps.cli:run
+
[test]
# py.test options when running `python setup.py test`
addopts = tests