aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorThomas Bechtold <thomas.bechtold@canonical.com>2022-06-21 10:24:42 +0200
committerThomas Bechtold <thomas.bechtold@canonical.com>2022-06-21 10:24:42 +0200
commit34c9769714f6239e97808ba12fe3083d41b09c88 (patch)
treefd716937eec8fffe5262504dd95fa91921ea7471 /setup.py
parent5dd7f4c4b6d4d771c5b6866b8256eb1bad632843 (diff)
downloadgit-deps-34c9769714f6239e97808ba12fe3083d41b09c88.tar.gz
Drop setuptools-markdown
Stop using setuptools-markdown which is no longer maintained and doesn't work anymore. Instead use the long_description_content_type variable (see [0]) to indicate that the given long_description is in markdown format. This fixes: AttributeError: module 'pypandoc' has no attribute 'convert' [0] https://dustingram.com/articles/2018/03/16/markdown-descriptions-on-pypi/ Fixes #112
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index 4b84cc1..6f11ee4 100644
--- a/setup.py
+++ b/setup.py
@@ -19,9 +19,9 @@ def setup_package():
setup_requires=[
'six',
'pyscaffold>=2.5.10,<2.6a0',
- 'setuptools-markdown',
] + sphinx,
- long_description_markdown_filename='README.md',
+ long_description='README.md',
+ long_description_content_type="text/markdown",
use_pyscaffold=True
)