aboutsummaryrefslogtreecommitdiffstats
path: root/setup.cfg
diff options
context:
space:
mode:
authorMatěj Cepl <mcepl@cepl.eu>2024-04-29 10:22:27 +0200
committerMatěj Cepl <mcepl@cepl.eu>2024-04-29 10:22:27 +0200
commitd2362a629d9871f535493b2ff92bcad415ae6dcd (patch)
tree61008eb7d84aff15e9b551b4e37d8cd7c94099b4 /setup.cfg
parent89d51e87a3fe4bdcb1efabbe7a4923958998a61c (diff)
downloadgit-deps-d2362a629d9871f535493b2ff92bcad415ae6dcd.tar.gz
Standardize and modernize package configuration.
Diffstat (limited to 'setup.cfg')
-rw-r--r--setup.cfg40
1 files changed, 21 insertions, 19 deletions
diff --git a/setup.cfg b/setup.cfg
index 4204b45..86d82ce 100644
--- a/setup.cfg
+++ b/setup.cfg
@@ -1,6 +1,8 @@
[metadata]
name = git-deps
-summary = automatically detect dependencies between git commits
+description = automatically detect dependencies between git commits
+long_description = file: README.md
+long_description_content_type = text/markdown
author = Adam Spiers
author_email = git@adamspiers.org
license = GPL-2+
@@ -19,7 +21,22 @@ classifier =
Topic :: Software Development :: Version Control
Topic :: Utilities
-[entry_points]
+[options]
+packages =
+ git_deps
+install_requires =
+ pygit2 >= 0.24.0
+ flask
+ sphinx
+ pyscaffold
+
+[options.extras_require]
+testing =
+ pytest-cov
+ pytest
+ flake8
+
+[options.entry_points]
console_scripts =
git-deps = git_deps.cli:run
gitfile-handler = git_deps.handler:run
@@ -30,24 +47,9 @@ scripts =
data_files =
share/git_deps = share/gitfile-handler.desktop
-[options]
-packages =
- git_deps
-
-[options.entry_points]
-console_scripts =
- git-deps = git_deps.cli:run
-
-[test]
-# py.test options when running `python setup.py test`
-addopts = tests
-
-[pytest]
-# Options for py.test:
-# Specify command line options as you would do when invoking py.test directly.
-# e.g. --cov-report html (or xml) for html/xml output or --junitxml junit.xml
-# in order to write a coverage file that can be read by Jenkins.
+[tool:pytest]
addopts =
+ tests
--cov git_deps --cov-report term-missing
--verbose