aboutsummaryrefslogtreecommitdiffstats
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix34
1 files changed, 34 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 00000000..10cb36bf
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,34 @@
+{
+ description = "workspace configuration for git-bug";
+
+ inputs = {
+ nixpkgs.url = "github:nixos/nixpkgs/nixos-unstable";
+ flake-utils.url = "github:numtide/flake-utils";
+ };
+
+ outputs =
+ {
+ self,
+ flake-utils,
+ nixpkgs,
+ }:
+ flake-utils.lib.eachDefaultSystem (
+ system:
+ let
+ pkgs = nixpkgs.legacyPackages.${system};
+ in
+ {
+ devShell = pkgs.mkShell {
+ packages = with pkgs; [
+ codespell
+ gh
+ git
+ go
+ golangci-lint
+ nixfmt-rfc-style
+ nodePackages.prettier
+ ];
+ };
+ }
+ );
+}