aboutsummaryrefslogtreecommitdiffstats
path: root/pyproject.toml
diff options
context:
space:
mode:
Diffstat (limited to 'pyproject.toml')
-rw-r--r--pyproject.toml65
1 files changed, 65 insertions, 0 deletions
diff --git a/pyproject.toml b/pyproject.toml
new file mode 100644
index 0000000..6db2b6f
--- /dev/null
+++ b/pyproject.toml
@@ -0,0 +1,65 @@
+[build-system]
+requires = ["setuptools>=64", "setuptools_scm>=8"]
+build-backend = "setuptools.build_meta"
+
+[project]
+name = "bugs-everywhere"
+# version = "1.1"
+dynamic = ["version"]
+license = {text = "GNU General Public License (GPL)"}
+authors = [
+ { name = "W. Trevor King", email = "wking@tremily.us" }
+]
+classifiers = ["Development Status :: 4 - Beta",
+ "Environment :: Console",
+ "Environment :: Web Environment",
+ "Framework :: CherryPy",
+ "Intended Audience :: Customer Service",
+ "Intended Audience :: Developers",
+ "Intended Audience :: End Users/Desktop",
+ "License :: OSI Approved :: GNU General Public License (GPL)",
+ "License :: OSI Approved :: GNU General Public License v2 (GPLv2)",
+ "License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)",
+ "License :: OSI Approved :: GNU General Public License v3 (GPLv3)",
+ "Operating System :: OS Independent",
+ "Programming Language :: Python",
+ "Programming Language :: Python :: 2.7",
+ "Topic :: Software Development :: Bug Tracking"
+]
+description = "Bugtracker supporting distributed revision control"
+readme = "README"
+
+[tool.setuptools_scm]
+
+
+# rev_id = version.version_info['revision']
+# rev_date = version.version_info['date']
+#
+# data_files = []
+#
+# man_path = os.path.join('doc', 'man', 'be.1')
+# if os.path.exists(man_path):
+# data_files.append(('share/man/man1', [man_path]))
+#
+# setup(
+# url='http://bugseverywhere.org/',
+# download_url=(
+# 'http://downloads.bugseverywhere.org/releases/be-{}.tar.gz'.format(
+# version.version())),
+# platforms=['all'],
+# long_description=open(os.path.join(_this_dir, 'README.rst'), 'r').read(),
+# packages=['libbe',
+# 'libbe.command',
+# 'libbe.storage',
+# 'libbe.storage.util',
+# 'libbe.storage.vcs',
+# 'libbe.ui',
+# 'libbe.ui.util',
+# 'libbe.util'],
+# scripts=['be'],
+# data_files=data_files,
+# requires=[
+# 'Jinja2 (>=2.6)',
+# 'CherryPy (>=3.2)',
+# ]
+# )