aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorW. Trevor King <wking@tremily.us>2012-10-25 19:34:06 -0400
committerW. Trevor King <wking@tremily.us>2012-10-25 19:34:06 -0400
commitdbbc38aa56cc1b5e8b06e8b9e3685ca7a6f79ee9 (patch)
tree8e960428c343fdcf3f0b03ba9ea605c8232f062d /setup.py
parent4c9d24ddf793b4779a66186eaaa28c8b9bc5e6d0 (diff)
downloadbugseverywhere-dbbc38aa56cc1b5e8b06e8b9e3685ca7a6f79ee9.tar.gz
setup.py: flesh out setup in preparation for PyPI posting
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py30
1 files changed, 29 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 709135d..cd49bf0 100755
--- a/setup.py
+++ b/setup.py
@@ -6,6 +6,8 @@ import os.path
from libbe import version
+_this_dir = os.path.dirname(__file__)
+
rev_id = version.version_info['revision']
rev_date = version.version_info['date']
@@ -18,8 +20,34 @@ if os.path.exists(man_path):
setup(
name='bugs-everywhere',
version='{}'.format(version.version()),
- description='Bugtracker supporting distributed revision control',
+ maintainer='W. Trevor King',
+ maintainer_email='wking@tremily.us',
url='http://bugseverywhere.org/',
+ download_url=(
+ 'http://downloads.bugseverywhere.org/releases/be-{}.tar.gz'.format(
+ version.version())),
+ license='GNU General Public License (GPL)',
+ platforms=['all'],
+ description='Bugtracker supporting distributed revision control',
+ long_description=open(os.path.join(_this_dir, 'README'), 'r').read(),
+ classifiers=[
+ 'Development Status :: 4 - Beta',
+ 'Environment :: Console',
+ 'Environment :: Web Environment',
+ 'Framework :: CherryPy',
+ 'Intended Audience :: Customer Service',
+ 'Intended Audience :: Developers',
+ 'Intended Audience :: End Users/Desktop',
+ 'License :: OSI Approved :: GNU General Public License (GPL)',
+ 'License :: OSI Approved :: GNU General Public License v2 (GPLv2)',
+ 'License :: OSI Approved :: GNU General Public License v2 or later (GPLv2+)',
+ 'License :: OSI Approved :: GNU General Public License v3 (GPLv3)'
+ 'Operating System :: OS Independent',
+ 'Programming Language :: Python',
+ 'Programming Language :: Python :: 2.7',
+ 'Topic :: Software Development :: Bug Tracking',
+ ],
+
packages=['libbe',
'libbe.command',
'libbe.storage',