aboutsummaryrefslogtreecommitdiffstats
path: root/setup.py
diff options
context:
space:
mode:
authorW. Trevor King <wking@tremily.us>2013-01-23 22:12:59 -0500
committerW. Trevor King <wking@tremily.us>2013-01-23 22:24:02 -0500
commit7d25e16bc419bc79951ada399b49223bef035cb6 (patch)
treec3772a173e17af104a64c7e35c97ec759e8efed4 /setup.py
parentb9e5c33dc96da7255740cc23660a183baafbadd4 (diff)
downloadbugseverywhere-7d25e16bc419bc79951ada399b49223bef035cb6.tar.gz
setup.py: Mention Jinja and CherryPy as requirements
Unfortunately, none of the current Python installation tools (easy_install, pip, others?) actaully use the `Requires` field that this populates [1,2], and it's gone since PEP 345, replaced by `Requires-Dist` [2,3,4]. Eventually a new packaging library (distutils2, packaging, distlib, ...) will land in the Python standard library and we can use whatever interface it provides for specifying dependencies [5]. [1]: http://blog.doughellmann.com/2007/11/requiring-packages-with-distutils.html [2]: http://ziade.org/2010/02/10/pep-345-and-386-accepted-summary-of-changes/ [3]: http://www.python.org/dev/peps/pep-0345/#requires-dist-multiple-use [4]: http://www.python.org/dev/peps/pep-0426/#requires-dist-multiple-use [5]: http://ncoghlan_devs-python-notes.readthedocs.org/en/latest/pep_ideas/core_packaging_api.html
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 4 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index cd49bf0..31d6551 100755
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,6 @@ setup(
'Programming Language :: Python :: 2.7',
'Topic :: Software Development :: Bug Tracking',
],
-
packages=['libbe',
'libbe.command',
'libbe.storage',
@@ -58,4 +57,8 @@ setup(
'libbe.util'],
scripts=['be'],
data_files=data_files,
+ requires=[
+ 'Jinja2 (>=2.6)',
+ 'CherryPy (>=3.2)',
+ ]
)